共计 624 个字符,预计需要花费 2 分钟才能阅读完成。
群晖更新 DSM 7 之后 docker 无法启动,特记录问题及解决方案。
问题症状
docker 启动报错:
PermissionError: [Errno 13] Permission denied:'config.ini'
问题原因
权限不足。
解决方案
设置 PUID,PGID:

首先是 PGID,和 PUID。Docker Hub readme 中解释了如何查看。
User / Group Identifiers
When using volumes (-v flags) permissions issues can arise between the host OS and the container, we avoid this issue by allowing you to specify the user PUID and group PGID.
Ensure any volume directories on the host are owned by the same user you specify and any permissions issues will vanish like magic.
In this instance PUID=1000 and PGID=1000, to find yours use id user as below:
$ id username
uid=1000(dockeruser) gid=1000(dockergroup) groups=1000(dockergroup)
gid 一般 100 是普通用户组,101 是管理员组。设置成 100 有时候会没权限,所以设成 101。







很久没更新了。
大佬,不知道过了这么久这个脚本还有没有在…
被投诉下线了。
点了那个链接?
被投诉下线了。
https://idea.hacks.t…